YorkHost - DDoS attack on Plesk – Incident details

All systems operational

DDoS attack on Plesk

Resolved
Major outage
Started 8 days agoLasted about 4 hours

Affected

Web

Partial outage from 9:56 PM to 11:10 PM, Degraded performance from 11:10 PM to 2:07 AM, Operational from 2:07 AM to 2:11 AM

Plesk Web01

Partial outage from 9:56 PM to 11:10 PM, Degraded performance from 11:10 PM to 2:07 AM, Operational from 2:07 AM to 2:11 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update
    We implemented a fix and are currently monitoring the result.
  • Update
    Update

    The geoblock remains active to limit the impact.

    A mitigation patch is still being tested with our service provider.

    Some users may experience slowdowns or temporary unavailability.

  • Update
    Update

    A modification is being made to mitigate the attack.

  • Monitoring
    Monitoring

    We have implemented geographic restrictions while waiting for the Anti-DDoS provider’s patch, scheduled for tomorrow.

    Protecting Plesk servers remains challenging due to their shared infrastructure, but we are actively working on long-term improvements.

    The service is currently partially restored.

  • Update
    Update

    Le service Plesk est toujours visé par une attaque de niveau L7.
    Nos équipes poursuivent le déploiement d’un correctif pour rétablir la stabilité.

  • Identified
    Identified

    Une attaque DDoS est actuellement en cours sur le service Plesk.
    Nos filtres avancés ont été activés afin de mitiger l’impact et rétablir la stabilité du service.