YorkHost - Client Area Performance Investigation – Incident details

All systems operational

Client Area Performance Investigation

Resolved
Operational
Started 1 day agoLasted about 3 hours

Affected

YorkHost Client / Billing

Degraded performance from 7:46 PM to 9:24 PM, Operational from 9:24 PM to 10:21 PM

YorkHost Beta Client / Billing

Degraded performance from 7:46 PM to 8:52 PM, Operational from 8:52 PM to 10:21 PM

Updates
  • Resolved
    Resolved

    No definitive fix has been identified at this stage.
    Average loading times within the Client Area remain around 5.4 seconds once logged in, which we consider within acceptable parameters.

    Given that the current Client Area will soon be deprecated, our team has decided to close this incident and focus efforts on the development of our next-generation client platform, currently in internal beta.

    If performance degradation becomes more significant or persistent, a new investigation will be opened accordingly.

  • Investigating
    Investigating

    Following further investigation, we have determined that the previous assumption regarding client area latency was incorrect.
    The initial analysis did not reflect the actual source of the issue. Our team has now refocused efforts on identifying the true root cause with updated diagnostic data.

    All hosted services continue to operate normally.
    A new update will be issued once the correct cause has been confirmed and mitigation steps are in place.

  • Identified
    Identified

    Our engineering team has identified the source of the latency affecting certain users within the YorkHost Client Area.
    The issue was traced to the HostBill notifications table, which had accumulated a large volume of records over time, leading to degraded query performance and slower page loading for some users.

    We are now implementing a permanent fix that includes database optimization, cleanup of redundant entries, and improved indexing to prevent recurrence.
    This process is being carried out carefully to maintain data integrity and avoid service interruptions.

    All hosting services, panels, and infrastructures remain fully operational, and the majority of users continue to experience normal access speeds.
    Further updates will be provided once the optimization work is fully completed.

  • Update
    Update

    Our team has not yet identified a precise root cause for the ongoing latency affecting the YorkHost Client Area.
    We are currently developing a detailed action plan to isolate and diagnose the issue more effectively across our systems.

    All hosting services and infrastructures remain fully operational.
    Further updates will be shared as soon as new information becomes available.

  • Investigating
    Investigating

    Our team is currently investigating reports of slow performance and latency within the YorkHost Client Area.
    Initial assessments indicate potential issues related to database response times and background API requests.

    We are actively analyzing logs and system metrics to identify the root cause and will implement corrective measures as soon as possible.
    All services and hosted infrastructures remain fully operational — this incident only affects the client interface speed and navigation.

    Next update will be provided once further diagnostics are completed.