YorkHost - FiveM Startup Crash – Incident details

All systems operational

FiveM Startup Crash

Resolved
Major outage
Started 2 days agoLasted about 7 hours
Updates
  • Resolved
    Resolved

    After reviewing multiple tickets, the resolution has been confirmed.
    Please update your FiveM artifacts to version:
    21547-0b6d5de3902cda6dd91be0c489d9b7243e554bb1
    All affected instances are now fully operational. Monitoring continues to ensure stability across all nodes.

  • Monitoring
    Monitoring

    Update:
    The issue has been resolved after updating the FXServer artifacts to version 21547-0b6d5de3902cda6dd91be0c489d9b7243e554bb1.
    All affected instances are now operating normally, and no further crashes have been observed.

    Resolution details:

    • Updated FXServer artifacts to the latest stable build

    • Confirmed compatibility with txAdmin and the new TXHOST_* environment variables

    • Deprecated ConVars removed from all configurations

    Monitoring will continue for next hours to ensure full stability across all nodes.

  • Investigating
    Investigating

    Impact: Some FiveM servers may crash on startup
    Affected systems: Instances running txAdmin on older Alpine-based eggs

    Details:
    We are investigating recent startup crashes affecting a subset of FiveM servers.
    Initial analysis indicates a compatibility issue between the latest FXServer artifacts and legacy Alpine/V8 libraries, combined with deprecated txAdmin configuration variables.

    Current actions:

    • Rolling back affected artifacts to restore service stability

    • Temporarily disabling txAdmin on impacted instances

    • Disable AntiCheat

    Next steps:
    All FiveM instances will be progressively migrated to the updated base image and configuration standard to prevent further instability.

    An update will be posted once the issue is fully mitigated.