YorkHost - PVE-02 Performance Issues – Incident details

All systems operational

PVE-02 Performance Issues

Resolved
Degraded performance
Started about 16 hours agoLasted 25 minutes

Affected

Virtualization Infrastructure

Degraded performance from 2:12 PM to 2:22 PM, Operational from 2:22 PM to 2:36 PM

PVE 02

Degraded performance from 2:12 PM to 2:22 PM, Operational from 2:22 PM to 2:36 PM

Updates
  • Resolved
    Resolved

    The issue on PVE-02 appears to be caused by a client virtual machine showing abnormal resource usage, leading to global latency across the node.
    We are implementing improved detection and usage limitation mechanisms to prevent a single VM (for example, a compromised one) from impacting the entire host.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Update
    Update

    Services under PVE-02, including Pterodactyl Resellers and VPS instances, may be temporarily powered off while we perform diagnostic tests.
    This maintenance is required to identify and fix the root cause of the issue.

    We will provide further updates once services are restored.

  • Investigating
    Investigating

    We are currently investigating problems affecting PVE-02, which may cause degraded performance or temporary unavailability of hosted services.
    Our technical team is checking system logs, storage health, and virtualization metrics to identify the root cause.

    Further updates will be provided as soon as new information is available.